Technologie > PHP

basic  Zurück  

Minimalanforderung 5.6

Der PepperShop profitiert von der schnellen PHP-Entwicklung und kann ab Version 5.6 verwendet werden.

Läuft auch mit PHP 7.0 / 7.1

Der PepperShop kann auch mit neuen PHP Versionen der Generation 7.0 und 7.1 betrieben werden.

PHP

Viele PHP-Konfigurationen werden berücksichtigt

Der PepperShop besitzt einen Konfigurationsabstraktionslayer, welcher dem Shopsystem erlaubt auf verschiedensten Systemen (Oracle, AIX, Linux, MacOS X, Windows, Apache, IIS, ...), mit vielen, unterschiedlichen PHP-Versionen und mit flexiblen PHP-Einstellungen betrieben werden. Detaillierte Infos findet man in den PepperShop Systemanforderungen.

An dieser Stelle sollen einige PHP-Direktiven genannt werden, deren Einstellung keinen Einfluss auf den Betrieb des PepperShops haben (mitunter auch deprecated):

  • safe_mode
  • register_globals
  • magic_quotes_gpc
  • session.auto_start
  • error_reporting
  • register_long_arrays
  • session.use_trans_sid
  • Funktionen: usleep / iconv / libiconv

Der PepperShop benutzt einen Konfigurationsabstraktionslayer und weitere Techniken um vom eingesetzten Webserver, der Anbindungsart von PHP (CGI / SAPI / Apache Modul / mod_ruid2) und von der PHP-Version und deren Direktiven möglichst unabhängig zu sein. Dies stellt sicher, dass der Shop auch bei Ihrem Provider ohne Probleme läuft.

» Siehe auch FAQ-Eintrag zu Systemvoraussetzungen



Zurück