Systemanforderungen für ältere PepperShop Versionen

Welche Systemanforderungen müssen für den PepperShop erfüllt sein?

Die Systemanforderungen für den PepperShop werden hier in fünf Teilen dargestellt:

  • Im ersten Abschnitt werden die Systemanforderungen für ein PepperShop System ab v.4.0 bis v.5.0 in der Version Basic / Professional / Enterprise dargestellt.
  • Im zweiten Abschnitt werden die Systemanforderungen für ein PepperShop System ab v.2.6 bis v.3.1 in der Version Basic / Professional / Enterprise dargestellt.
  • Im vierten und fünften Abschnitt werden die Systemanforderungen für die Versionen 2.0, 2.5 und alle älteren Shopversionen (etwas umfangreicher, da ältere Shopversionen noch mehr Einschränkungen hatten).
  • Ganz unten befindet sich ein Link zu den Systemanforderungen der aktuellen Shopversion

PepperShop v.4.0 - v.5.0: Basic / Professional Version:

  • UNIX System (z.B. Linux oder MacOS X) / Windows
  • PHP Version:
    • PepperShop v.5: PHP 5.4, 5.5, 5.6, (7.0 experimentell)
    • PepperShop v.4: PHP 5.4, 5.5 (5.6 ab Build 37)
  • GD-Library v.2+ mit JPEG und/oder PNG und/oder GIF Unterstützung für Artikelbilder
  • MySQL ab Version 5.1.23 (MySQL Version 5.6 empfohlen)
  • Optional: Um das SSH basierte Installationsscript zu benutzen: SSH-Zugang zum Webserver mit PERL Interpreter, ansonsten muss mittels FTP-Upload und der Anleitung 'Installation ohne Telnet/SSH' installiert werden. (Diese Anleitung findet man hier)
  • PHP Direktiven:
      - In disable_functions darf ini_set nicht ausgeschaltet sein (empfohlen = no value)
      - mbstring vorhanden und aktiv
      - memory_limit >= 64M sein (empfohlen >= 128M, wegen Bildharmonisierung)
      - max_input_vars > 1500 sein (empfohlen >= 3000) nur notwendig für
        Shop-Administration->Sprachen->'Alle übersetzten Texte anpassen'

Enterprise Version (zusätzlich):

  • Alle Systemanforderungen des PepperShops in der Version Basic / Professional
  • Linux/UNIX-Server
  • SSH-Zugang
  • PHP-Limitierungen 'max_execution_time' und 'memory_limit' müssen beliebig erhöht werden können (v.a. für grosse Systeme)!

PepperShop v.2.6 - v.3.1: Basic / Professional Version:

  • UNIX System (z.B. Linux oder MacOS X) / Windows
  • PHP Version 5.2, 5.3, 5.4 (5.5 experimentell)
  • GD-Library v.2.x mit JPEG und/oder PNG und/oder GIF Unterstützung für Artikelbilder
  • MySQL ab Version 5.0 bis 5.5 (DB-Backup: MySQL ab 5.1.23)
  • Um das Telnet/SSH basierte Installationsscript zu benutzen: Telnet oder SSH-Zugang zum Webserver, ansonsten muss mittels FTP-Upload und der Anleitung 'Installation ohne Telnet/SSH' installiert werden. (Diese Anleitung findet man hier)
  • PHP Direktiven:
      - In disable_functions darf ini_set nicht ausgeschaltet sein,
      - memory_limit >= 64M sein (empfohlen >= 128M)
      - zend.ze1_compatibility_mode muss ausgeschaltet sein (ab PHP 5.3 default)
      - max_input_vars > 1000 sein (empfohlen >= 2000) nur notwendig,
        wenn alle folgenden Punkte zutreffen: ab PHP V.5.3, ab PepperShop V.3.0 ,
        Shop-Administration->Sprachen->'Alle übersetzten Texte anpassen'

Enterprise Version (zusätzlich):

  • Alle Systemanforderungen des PepperShops in der Version Basic / Professional
  • Linux/Unix-Server
  • SSH oder Telnet Shell-Zugriff
  • PHP-Limitierungen 'max_execution_time' und 'memory_limit' müssen beliebig erhöht werden können!

PepperShop v.2.0 - v.2.5: Basic / Professional Versionen:

  • UNIX System (z.B. Linux oder MacOS X) / Windows
  • PHP ab Version 4.0.6 bis PHP 5.2
  • GD-Library v.1.84 oder v.2.0.x mit JPEG und/oder PNG und/oder GIF Unterstützung für Artikelbilder
  • MySQL ab Version 3.23.x / 4.0.x / 4.1.x / 5.0.x (empfohlen ist MySQL ab Version 4.1.0)
  • Um das Telnet/SSH basierte Installationsscript zu benutzen: Telnet oder SSH-Zugang zum Webserver, ansonsten muss mittels FTP-Upload und der Anleitung 'Installation ohne Telnet/SSH' installiert werden. (Diese Anleitung findet man hier)
  • PHP Direktiven: In disable_functions darf ini_set nicht ausgeschaltet sein, session.use_trans_sid sollte = Off sein (ab PepperShop v.2.5 egal), allow_call_time_pass_reference muss eingeschaltet sein (On)
  • Ab Shopversion 2.5 muss für die Shop-Administration memory_limit > 8M sein (empfohlen >= 16M) und die Direktive zend.ze1_compatibility_mode muss ausgeschaltet sein (ab PHP 5.3 default)

Infos: Zu noch älteren Shopversionen gibt es im jeweiligen README.txt Infos zu den damals aktuellen Systemanforderungen.

Aktuelle PepperShop Version